Service Interruption: Webhooks Signature Generation Issue
Incident Report for Dyte
Resolved



Date and Time: 15th Feb 12:18 GMT to 15th Feb 14:53 GMT


Affected Service: Webhooks


Issue: Our webhooks service experienced an interruption due to a broken signature generation logic. This issue affected the ability of clients to verify the authenticity of webhooks sent from our platform.


Root Cause: The signature generation logic used to verify webhooks was broken, leading to incorrect signature generation and validation.


Resolution: Our engineering team has identified and fixed the issue The correct signature generation process has been restored, ensuring that webhooks are properly signed and can be verified by clients.


Impact: The webhooks were being sent correctly during this time period but only clients who verified the webhooks were impacted.


Next Steps:


Testing: We will conduct thorough testing to ensure the stability and reliability of the webhooks service.
Monitoring: Our monitoring systems will be enhanced to promptly detect and alert on any similar issues in the future.
Posted Feb 15, 2024 - 20:30 IST