High Load and Signalling Degradation
Incident Report for Dyte
Resolved



Date and Time: 19th Apr 15:23 GMT to 19th Apr 15:44 GMT


Issue: Our web socket signalling layer experienced high load and subsequent degradation due to client side bug. This caused certain messages to amplify from each participant, resulting in a distributed spike of traffic that degraded our signalling services for a small percentage of our traffic.



Resolution: The network auto-healed itself within 10 minutes.


Impact: Degraded signalling services for a small percentage of traffic. Temporary disruption in communication for affected users.


Next Steps:
Fix the underlying client bug that amplified messages.
Implementing server-side countermeasures for handling unexpected traffic volume to prevent future occurrences.
Continued monitoring and optimization of the signalling layer.

Posted Apr 19, 2024 - 21:00 IST