Degradation of the Recording Service

Incident Report for Dyte

Postmortem

Summary
Between 07:07 UTC and 07:31 UTC on December 30, we experienced a service degradation that caused new recording requests to fail with HTTP 500 errors.

Date time
Start time: 2025-12-30 07:07:00 UTC
Fix time: 2025-12-30 07:31:00 UTC

Detailed analysis
The issue was triggered by an isolated traffic spike from a single organization that bypassed our global thresholds. This surge in traffic caused resource contention, resulting in failures for new recording requests.

Mitigation
Our team detected the issue immediately. Service was restored by identifying and blocking the specific source responsible for the traffic spike.

Next Steps
Implementing enhanced rate limits to prevent similar occurrences in the future.

Posted Dec 30, 2025 - 15:49 IST

Resolved

We experienced a service degradation that caused new recording requests to fail with HTTP 500 errors. This was triggered by an isolated traffic spike from a single organization that bypassed our global thresholds. Our team detected the issue immediately and restored service by blocking the specific source
Posted Dec 30, 2025 - 12:30 IST