Service Interruption: Video Calls unavailable for a subset of customers
Incident Report for Dyte
Resolved
Resolved - Date and Time: 31st July 05:06 UTC to 31st July 05:36 UTC

Affected Service: Video Calls

Issue: Video calls on the new media layer were unavailable for a period of about 30 minutes.

Root Cause: A change was rolled out to how we manage scaling for our media nodes, which had a bug in allocating new calls to nodes.

Resolution: We rolled back the change and stabilised the system by temporarily provisioning additional nodes.

Impact: Existing calls abruptly ended, and new calls would not have started due to this interruption. This only affected organisations using the new media layer. The older media layer continued functioning, and some calls would have been rerouted to the working systems.

Next Steps:

* Review testing practices to include testing for multiple call allocations in lower environments
* Share additional details in an RCA.
Posted Jul 31, 2024 - 10:30 IST